Настройка IDE

На этой стадии мы предполагаем что вы уже склонировали и скомпилировали Godot.

Вы можете легко разрабатывать Godot из любого текстового редактора и вызывать scons из командной строки, но если вы хотите разрабатывать с помощью IDE (Integrated Development Environment), здесь вы можете найти инструкции для самых популярных:

Возможно использовать и другие IDE, но их настройка ещё не задокументирована.

Qt Creator

Импортирование проекта

  • Выберите New Project -> Import Project -> Import Existing Project.
../../_images/qtcreator-new-project.png
  • Установить путь к корневой директории Godot и введите имя проекта.
../../_images/qtcreator-set-project-path.png
  • Здесь вы можете выбрать какие папки и файлы будут видимы в проекте. Файлы C/C++ добавляются автоматически. Потенциально хорошо добавить: *.py для конфигурационных файлов, *.java для разработки под Android, *.mm для macOS. Щёлкните «Next».
../../_images/qtcreator-apply-import-filter.png
  • Щёлкните Finish.
  • Добавьте строку содержащую . в project_name.includes для включения функции авто-завершения кода.
../../_images/qtcreator-project-name-includes.png

Сборка и запуск

Конфигурация сборки:

  • Щёлкните Projects и откройте вкладку Build.
  • Удалите предустановленный этап сборки make.
../../_images/qtcreator-projects-build.png
  • Щёлкните Add Build Step -> Custom Process Step.
../../_images/qtcreator-add-custom-process-step.png
  • Выберите scons во поле Command. Если он будет ругаться „Could not start process «scons»“, это будет означать что scons не установлен в переменной среды PATH, так что вам нужно будет установить полный путь к бинарнику SCons.
  • Заполните поле Arguments вашими опциями компиляции. (напр.: p=x11 target=debug -j 4)
../../_images/qtcreator-set-scons-command.png

Конфигурация запуска:

  • Откройте вкладку Run.
  • Настройте Executable на скомпилированный бинарный файл Godot (напр.: %{buildDir}/bin/godot.x11.opt.tools.64)
  • Если вы хотите запустить определённую игру или проект, настройте Working directory на директорию игры.
  • Если вы хотите запустить редактор, добавьте -e в поле Command line arguments.
../../_images/qtcreator-run-command.png

Обновление источников после получения последних коммитов

Как разработчик вы обычно хотите часто получать последние коммиты из главного git репозитория или определённого форка итд. Хотя это приводит к маленькой проблеме: так как разработка продолжается, исходные файлы (и папки) добавляются или удаляются. Эти изменения нужно также отразить в ваших проектных файлах для Qt Creator, чтобы вы смогли продолжить кодинг. Простейший способ проверки этого, просто кликнуть правой кнопкой мыши по вашей корневой папке в «Projects View» и кликнуть по «Edit files…»

../../_images/qtcreator-edit-files-menu.png

Now a new dialog should appear that is similar in functionality to the one in the third step of the «Importing the project» section. Here now you can check whether you want to add/remove specific files and/or folders. You can chose by clicking with your mouse or just simply by clicking the «Apply Filter» button. A simple click on «Ok» and you’re ready to continue your work.

../../_images/qtcreator-edit-files-dialog.png

Конфигурация стилей кода

Разработчики должны следовать проектным стилям кода и IDE должно помогать им в этом. По умолчанию, Qt Cretor использует пробелы для отступов что некорректно в проектах на Godot. Вы можете изменить это поведение в «Code Style» в Options -> C++.

../../_images/qtcreator-options-cpp.png

Щёлкнув по Edit вы измените текущие настройки, после кликните по кнопке Copy Built-in Code Style для установки нового стиля кода. Установить имя (напр. Godot) и измените настройку вкладок в Tabs Only.

../../_images/qtcreator-edit-codestyle.png

KDevelop

KDevelop это бесплатная, открытая IDE для всех десктопных платформ.

Вы можете найти видео обучения здесь. Или вы можете следовать инструкциям в текстовом виде далее.

Начните с открытия KDevelop и выбирания «open project».

../../_images/kdevelop_newproject.png

Выберите директорию где вы склонировали Godot.

На следующем экране, выберите «Custom Build System» для Project manager.

../../_images/kdevelop_custombuild.png

Теперь, когда проект импортирован, откройте конфигурацию проекта.

../../_images/kdevelop_openconfig.png

Добавьте следующие инклуды/импорты:

.  // a dot to indicate the root of the Godot project
core/
core/os/
core/math/
drivers/
platform/x11/  // make that platform/osx/ if you're using macOS
../../_images/kdevelop_addincludes.png

Примените изменения.

Переключитесь на вкладку «Custom Build System». Добавьте сонфигурацию сборки и сохраните бланк директории сборки. Включите утилиты сборки и добавьте scons как ваш исполняемый файл и platform=x11 target=debug (platform=osx если вы используете macOS) как аргументы.

../../_images/kdevelop_buildconfig.png

Затем вы должны сообщить KDevelop где найти исполняемый файл. Из меню «Run» выберите «Configure Launches».

../../_images/kdevelop_configlaunches.png

Кликните по «Add» если лаунчер отсутствует. Затем добавьте путь к экзешнику в секции исполнямых файлов. Ваш исполняемый файл должен находиться в под-директории bin/ и должен иметь имя подобное godot.x11.tools.64 (имя может быть немного другим в зависимости от вашей платформы и ваших опций сборки).

../../_images/kdevelop_configlaunches2.png

Отлично ! Теперь всё хорошо :)

Xcode

Настройка проекта

  • Создаёте внешний проект Xcode в любом месте
../../_images/xcode_1_create_external_build_project.png
  • Установите Build tool на путь до scons

Измените Цели Сборки во вкладке Xcode Info Tab:

  • Установите Arguments на что-то подобное: platform=osx tools=yes bits=64 target=debug
  • Установите Directory на путь к папке исходного кода Godot. Оставьте его пустым если проект уже установлен.
  • Вы можете снять флажок Pass build settings in environment
../../_images/xcode_2_configure_scons.png

Добавьте Цель Командной Строки:

  • Зайдите в Xcode File > New > Target… и добавьте новую цель командной строки Xcode
../../_images/xcode_3_add_new_target.png ../../_images/xcode_4_select_command_line_target.png
  • Назовите её так, чтобы вы запомнили что её не надо компилировать
  • напр. GodotXcodeIndex
  • Перейдите на вкладку Build Settings и поищите Header Search Paths
  • Установите Header Search Paths на абсолютный путь к папке исходных кодов Godot
  • Сделайте её рекурсивной добавив две * в конец пути
  • напр. /Users/me/repos/godot-source/\**

Добавьте Исходный Код Godot в Проект:

  • Перетащите исходный код Godot в браузер файлов проекта.
  • Снимите флажок Create External Build System
../../_images/xcode_5_after_add_godot_source_to_project.png
  • Щёлкните Next
  • Выберите create groups
../../_images/xcode_6_after_add_godot_source_to_project_2.png
  • Выберите только свою командную строку цели в разделе Add to targets
  • Щёлкните finish. Xcode начнёт индексировать файлы.
  • Примите чашечку кофе… Возможно перекусите, также
  • Вы сможете перейти к определению, настройкам авто завершения, и полной подсветке синтаксиса когда процесс закончится.

Настройка схемы

Редактируйте Схему Сборки для Внешней Цели Сборки:

  • Откройте редактор схемы внешней цели сборки
  • Разверните меню Build
  • Перейдите в Post Actions
  • Добавьте новый скрипт запуска, выберите ваш проект в Provide build settings from так как это позволит вам использовать переменную ${PROJECT_DIR}.
../../_images/xcode_7_setup_build_post_action.png
  • Напишите скрипт чтобы дать имя исполняемому файлу которое поймёт Xcode
  • напр. ln -f ${PROJECT_DIR}/godot/bin/godot.osx.tools.64 ${PROJECT_DIR}/godot/bin/godot
  • Постройте внешнюю цель сборки

Редактируйте Схему Запуска во Внешней Цели Сборки:

  • Откройте редактор схем снова
  • Кликните Run
../../_images/xcode_8_setup_run_scheme.png
  • Установите Executable на файл который вы присоединили к вашему скрипту сборки
  • Проверьте Debug executable если он уже не установлен
  • Вы можете перейти во вкладку Arguments и добавить -e и -path для проекта чтобы отлаживать редактор, а не экран выбора проекта

Протестируйте это:

  • Установите точку отладки в platform/osx/godot_main_osx.mm
  • Он должен останавливаться на этой точке!

Visual Studio Code

  • Убедитесь что расширение C/C++ установлено. Вы можете найти инструкции в документации.
  • Теперь откройте склонированную папку godot в VS Code (File > Open Folder…)

Для того чтобы построить проект, нам нужно конфигурационные файлы: launch.json и tasks.json. Для их создания:

  • Откройте Debug view (Ctrl + Shift + D) и выберите колёсико с оранжевой точкой:
../../_images/vscode_1_create_launch.json.png
  • Выберите C++ (GDB/LLDB) (она может называться слегка по другому в macOS или Windows)
  • Обновите launch.json для соответствия:
../../_images/vscode_2_launch.json.png

(Заметьте что godot.x11.tools.64 в значении «program» может слегка отличаться в macOS или Windows)

  • Создайте tasks.json запустив Debug process (F5). VS Code покажет окно с кнопкой Configure Task. Щёлкните по ней и выберите Create tasks.json file from template, затем выберите Others
  • Обновите tasks.json до соответствия:
../../_images/vscode_3_tasks.json.png

(Заметьте что platform=x11 может слегка отличаться для macOX и Windows)

  • Теперь вы можете запустить процесс отладки снова и протестировать что всё работает.
  • If the build phase fails, check the console for hints. On Linux it’s most likely that some dependencies are missing. Check Compiling for X11 (Linux, *BSD)