Qt Creator

Qt Creator est un IDE gratuit et open source pour toutes les plateformes de bureau.

Importation du projet

  • Dans l'écran principal de Qt Creator, sélectionnez New Project > Import Project > Import Existing Project.
../../../_images/qtcreator-new-project.png
  • Sous Location, sélectionnez le dossier racine de Godot.
../../../_images/qtcreator-set-project-path.png
  • Ensuite, vous pouvez choisir les dossiers et fichiers qui seront visibles au projet. Les fichiers C/C++ seront ajoutés automatiquement, d'autres extensions peuvent être potentiellement utiles : *.py pour les fichiers du système de compilation, *.java pour le développement Android, *.mm pour le développement macOS.
../../../_images/qtcreator-apply-import-filter.png

Note

Vous pouvez modifier cette configuration ultérieurement en faisant un clic droit sur votre projet et en sélectionnant l'option Edit Files....

../../../_images/qtcreator-edit-files-menu.png
  • Terminer l'importation.
  • Ouvrez le fichier project_name.includes et ajoutez-y une ligne contenant . pour activer correctement la complétion du code.
../../../_images/qtcreator-project-name-includes.png
  • Dans le menu de gauche, sélectionnez Projects et ouvrez l'onglet Build.
  • Supprimer l'étape de construction prédéfinie make.
../../../_images/qtcreator-projects-build.png
  • Cliquez sur Add Build Step > Custom Process Step pour ajouter une nouvelle étape de compilation avec les paramètres suivants :

    Commande scons
    Arguments Voir Introduction au buildsystem pour une liste complète des arguments.
../../../_images/qtcreator-set-scons-command.png

Note

Si la compilation échoue avec Could not start process "scons", cela peut signifier que scons n'est pas dans votre variable d'environnement PATH. Dans ce cas, vous devrez spécifier le chemin complet vers le binaire SCons.

Débogage du projet

  • Dans le menu de gauche, sélectionnez Projects et ouvrez l'onglet Run.
  • Sous Executable, indiquez le chemin d'accès à votre exécutable situé dans le dossier <Godot root directory>/bin. Le nom dépend de votre configuration de compilation, par exemple godot.x11.tools.64 pour une plate-forme X11 64 bits avec tools activé. Vous pouvez utiliser %{buildDir} pour faire référence à la racine du projet, par exemple : %{buildDir}/bin/godot.x11.opt.tools.64.
  • Si vous voulez exécuter un projet spécifique, indiquez son dossier racine sous Working directory.
  • Si vous voulez exécuter l'éditeur, ajoutez -e au champ Command line arguments.
../../../_images/qtcreator-run-command.png

Pour en savoir plus sur les arguments de la ligne de commande, reportez-vous au tutoriel de la ligne de commande.

Configuration du style de code

Les développeurs doivent suivre le code style du projet et l'IDE devrait les aider à le faire. Par défaut, Qt Creator utilise des espaces pour l'indentation, ce qui ne correspond pas aux directives de style de code de Godot. Vous pouvez changer ce comportement en modifiant le Code Style dans Options > C++.

../../../_images/qtcreator-options-cpp.png

Cliquez sur Edit pour modifier les paramètres actuels, puis cliquez sur le bouton**Copy Built-in Code Style** pour définir un nouveau style de code. Donnez-lui un nom (par exemple, Godot) et modifiez la politique de tabulation pour qu'elle soit Tabs Only.

../../../_images/qtcreator-edit-codestyle.png

Si vous rencontrez des problèmes, demandez de l'aide sur l'un des canaux communautaires de Godot.