IDEの構成

すでにGodotのクローンを作成 し、コンパイルしたとします。

You can easily develop Godot with any text editor and by invoking scons on the command line, but if you want to work with an IDE (Integrated Development Environment), here are setup instructions for some popular ones:

It is possible to use other IDEs, but their setup is not documented yet.

Qt Creator

プロジェクトのインポート

  • 新しいプロジェクト -> プロジェクトのインポート -> 既存のプロジェクトインポートを を選択します。
../../_images/qtcreator-new-project.png
  • Godotルートディレクトリへのパスを設定し、プロジェクト名を入力します。
../../_images/qtcreator-set-project-path.png
  • ここでは、プロジェクトに表示するフォルダとファイルを選択できます。C/C++ファイルは自動的に追加されます。便利な追加機能:ビルドシステムファイルの *.py、Android 開発用 *.java、macOS用 *.mm。「次へ」 をクリックします。
../../_images/qtcreator-apply-import-filter.png
  • 終了をクリックします。
  • . を含む行をproject_name.includesに追加して、作業コードの完了を取得します。
../../_images/qtcreator-project-name-includes.png

ビルドと実行

ビルド構成:

  • プロジェクトをクリックし、ビルドタブを開きます。
  • 定義済みの make ビルド ステップを削除します。
../../_images/qtcreator-projects-build.png
  • ビルドステップを追加 -> カスタムプロセスステップをクリックします。
../../_images/qtcreator-add-custom-process-step.png
  • Type scons in the Command field. If it fails with 'Could not start process "scons"', it can mean that scons is not in your PATH environment variable, so you may have to use the full path to the SCons binary.
  • 引数フィールドにコンパイルオプションを入力します。(例: p=x11 target=debug -j 4 )
../../_images/qtcreator-set-scons-command.png

構成の実行:

  • 実行タブを開きます。
  • Point the Executable to your compiled Godot binary (e.g: %{buildDir}/bin/godot.x11.opt.tools.64)
  • 特定のゲームまたはプロジェクトを実行する場合は、作業ディレクトリをゲームディレクトリに指定します。
  • エディタを実行する場合は、コマンドライン引数フィールドに -e を追加します。
../../_images/qtcreator-run-command.png

Updating sources after pulling latest commits

As a developer you usually want to frequently pull the latest commits from the upstream git repository or a specific fork etc. However this brings a little problem with it: as the development continues, source files (and folders) are added or removed. These changes needs to be reflected in your project files for Qt Creator too, so you continue to have a nice experience coding in it. A simple way to check is to right click at your root folder in the "Projects View" and click on "Edit files..."

../../_images/qtcreator-edit-files-menu.png

Now a new dialog should appear that is similar in functionality to the one in the third step of the "Importing the project" section. Here you can check whether you want to add/remove specific files and/or folders. You can chose by clicking with your mouse or just simply by clicking the "Apply Filter" button. A simple click on "Ok" and you're ready to continue your work.

../../_images/qtcreator-edit-files-dialog.png

Code style configuration

Developers must follow the project's code style and IDE should help them to do it. By default, Qt Creator does use spaces for indentation which is incorrect for Godot project. You can change this behavior by changing the "Code Style" in Options -> C++.

../../_images/qtcreator-options-cpp.png

Click on Edit to change the current settings, then click on Copy Built-in Code Style button to set a new code style. Set a name for it (e.g. Godot) and change the Tab policy to be Tabs Only.

../../_images/qtcreator-edit-codestyle.png

KDevelop

KDevelop is a free, open source IDE for all desktop platforms.

ビデオチュートリアルはこちらです。または、このテキストバージョンのチュートリアルに従ってください。

Start by opening KDevelop and choosing "open project".

../../_images/kdevelop_newproject.png

Godotのクローンを作成したディレクトリを選択します。

On the next screen, choose "Custom Build System" for the Project manager.

../../_images/kdevelop_custombuild.png

プロジェクトがインポートされたので、プロジェクトのコンフィグを開きます。

../../_images/kdevelop_openconfig.png

次のインクルード/インポートを追加します:

.  // a dot to indicate the root of the Godot project
core/
core/os/
core/math/
drivers/
platform/x11/  // make that platform/osx/ if you're using macOS
../../_images/kdevelop_addincludes.png

Apply the changes.

Switch to the "Custom Build System" tab. Add a build configuration and keep the build directory blank. Enable build tools and add scons as the executable then add platform=x11 target=debug (platform=osx if you're on macOS) as the arguments.

../../_images/kdevelop_buildconfig.png

Next we need to tell KDevelop where to find the binary. From the "Run" menu, choose "Configure Launches".

../../_images/kdevelop_configlaunches.png

Click "Add" if no launcher exists. Then add the path to your executable in the executable section. Your executable should be located in the bin/ sub-directory and should be named something like godot.x11.tools.64 (the name could be different depending on your platform and depending on your build options).

../../_images/kdevelop_configlaunches2.png

以上です!これで準備完了です (^^)

Xcode

プロジェクトの設定

  • 任意の場所にXcode外部ビルドプロジェクトを作成する
../../_images/xcode_1_create_external_build_project.png
  • ビルドツールをsconsへのパスに設定します

ビルドターゲットのXcode情報タブを変更します:

  • 引数を次のようなものに設定します: platform=osx tools=はい bits=64 target=debug
  • Directoryを Godot のソース フォルダへのパスに設定します。プロジェクトが既に存在する場合は、空白のままにします。
  • 環境内のビルド設定を渡すのチェックを外すことができます
../../_images/xcode_2_configure_scons.png

コマンドラインターゲットの追加:

  • [Xcodeファイル]> [新規]> [ターゲット...]に移動し、新しいXcodeコマンドラインターゲットを追加します
../../_images/xcode_3_add_new_target.png ../../_images/xcode_4_select_command_line_target.png
  • このターゲットでコンパイルしないように名前を付けます
  • 例: GodotXcodeIndex
  • 新しく作成したターゲットのビルド設定タブに移動し、ヘッダー検索パスを検索します
  • ヘッダー検索パスをGodotのソースフォルダへの絶対パスに設定する
  • パスの末端に 「**」を追加して再帰的にする
  • 例: /Users/me/repos/godot-source/\**

プロジェクトにGodotソースを追加する:

  • Drag and drop Godot source into project file browser.
  • チェックを外す: 外部ビルド システムの作成
../../_images/xcode_5_after_add_godot_source_to_project.png
  • 次へをクリックします
  • グループの作成を選択
../../_images/xcode_6_after_add_godot_source_to_project_2.png
  • ターゲットに追加セクションでコマンドラインターゲットのみをオフにします
  • 終了をクリックします。次に、Xcodeがファイルのインデックスを作成します。
  • コーヒーを1杯取って...もしかしたら、何か食べるものも作るかもしれません
  • 定義、自動補完、および完全な構文の強調表示が完了したら、その定義にジャンプする必要があります。

スキームのセットアップ

外部ビルドターゲットのビルドスキームの編集:

  • 外部ビルドターゲットのオープンスキームエディタ
  • ビルドメニューを展開する
  • アクションの投稿へ飛ぶ
  • 新しいスクリプト実行アクションを追加し、 Provide build settings from でプロジェクトを選択すると、 ${PROJECT_DIR} 変数を使用することができます。
../../_images/xcode_7_setup_build_post_action.png
  • Xcodeが認識する名前をバイナリに与えるスクリプトを記述する
  • 例: ln -f ${PROJECT_DIR}/godot/bin/godot.osx.tools.64 ${PROJECT_DIR}/godot/bin/godot
  • 外部ビルドターゲットの構築

外部ビルドターゲットの実行スキームの編集:

  • スキームエディタを再度開きます
  • 実行をクリック
../../_images/xcode_8_setup_run_scheme.png
  • Executableを、ビルド後のアクションスクリプトでリンクしたファイルに設定します
  • まだ実行されていない場合は、デバッグ実行可能ファイルをチェックします
  • 引数タブに移動し、プロジェクトに -e と -path を追加して、プロジェクト選択画面ではなくエディタをデバッグできます

それをテストします:

  • プラットフォーム /osx/godot_main_osx.mm でブレークポイントを設定する
  • そのポイントで壊れるはずです!

Visual Studio Code

  • Ensure that C/C++ extension is installed. You can find instructions in docs.
  • Now open cloned godot folder in VS Code (File > Open Folder...)

In order to build the project, we need two configuration files: launch.json and tasks.json. To create them:

  • Open Debug view (Ctrl + Shift + D) and select cogwheel with an orange dot:
../../_images/vscode_1_create_launch.json.png
  • Select C++ (GDB/LLDB) (it might be named differently on macOS or Windows)
  • Update launch.json to match:
../../_images/vscode_2_launch.json.png

(Note that godot.x11.tools.64 in "program" value might be named differently on macOS or Windows)

  • Create tasks.json by starting the Debug process (F5). VS Code will show a dialog with a Configure Task button. Tap it and select Create tasks.json file from template, then select Others
  • Update tasks.json to match:
../../_images/vscode_3_tasks.json.png

(Note that platform=x11 will be different for macOX and Windows)

  • You can now start the Debug process again to test that everything works.
  • If the build phase fails, check the console for hints. On Linux it's most likely that some dependencies are missing. Check Compiling for X11 (Linux, *BSD)

Android Studio

Android Studio is a Jetbrain IDE for Android development. It has a feature-rich editor which supports Java and C/C++, so it can be used for development of the Godot core engine, and Android platform codebases.

プロジェクトの設定

  • From the Android Studio Welcome to Android Studio window, select Open an existing Android Studio project
../../_images/android_studio_setup_project_1.png
  • Navigate to <godot root directory>/platform/android/java and select the settings.gradle gradle file.
  • Android Studio will import and index the project.
  • To build the project, follow the compiling instructions.

CLion

CLion is a commercial IDE for C++. It requires a CMakeLists.txt file as a project file, which is problematic for Godot which uses the SCons buildsystem and not CMake. However, there is a CMakeLists.txt configuration for Android Studio which can also be used by CLion.

  • Choose File -> Open.
  • Navigation to your Godot Git clone, and select the folder platform/android/java/lib (the CMakeLists.txt file is located there). Select the folder, not the CMakeLists.txt file. Then click Ok.
../../_images/clion_1_open.png
  • If this popup window appears, select This window to open the project.
../../_images/clion_2_this_window.png
  • Choose Tools -> CMake -> Change Project Root and select the root Godot folder.
../../_images/clion_3_change_project_root.png
  • You should be now be able to see all the project files. Autocomplete should work, when the project finish indexing.