配置 IDE

We assume that you have already cloned and compiled Godot.

您可以使用任何文本编辑器和通过在命令行上调用 scons 来轻松开发Godot,但是如果您要使用IDE(集成开发环境),则有一些常用的设置说明:

可以使用其他IDE,但尚未记录其设置。

Qt Creator

导入项目

  • 选择 新建项目(New Project) -> 导入项目(Import Project) -> 导入现有项目(Import Existing Project)
../../_images/qtcreator-new-project.png
  • 将路径设置为Godot根目录,然后输入项目名称。
../../_images/qtcreator-set-project-path.png
  • 在这里,您可以选择对项目可见的文件夹和文件。C/C++文件会自动添加。潜在的有益补充:*.py 为构建系统文件,*.java 用于Android开发,*.mm 用于MacOS。点击“下一步”。
../../_images/qtcreator-apply-import-filter.png
  • 点击 完成(Finish)
  • project_name.includes 文件中添加新行 . 以完成工作代码。
../../_images/qtcreator-project-name-includes.png

构建和运行

构建配置:

  • 点击 项目(Projects) 并打开 构建(Build) 选项卡。
  • 删除预先定义的 make 构建步骤。
../../_images/qtcreator-projects-build.png
  • 点击 添加构建步骤(Add Build Step) -> 自定义构建步骤(Custom Process Step)
../../_images/qtcreator-add-custom-process-step.png
  • 命令(Command) 字段中输入 scons 。如果失败并提示 无法启动进程 "scons",则可能意味着 scons 不在您的 PATH 环境变量中,因此您可能必须使用SCons二进制文件的完整路径。
  • 参数(Arguments) 字段填入您的构建选项。(例如:p=x11 target=debug -j 4
../../_images/qtcreator-set-scons-command.png

运行配置:

  • 打开 运行(Run) 选项卡。
  • 可执行文件(Executable) 指向编译的Godot二进制文件(例如:%{buildDir}/bin/godot.x11.opt.tools.64
  • 如果要运行特定的游戏或项目,请将 工作目录(Working directory) 指向游戏目录。
  • 如果要运行编辑器,请在 命令行参数 字段中添加 -e
../../_images/qtcreator-run-command.png

拉取最新提交后更新源文件

As a developer you usually want to frequently pull the latest commits from the upstream git repository or a specific fork etc. However this brings a little problem with it: as the development continues, source files (and folders) are added or removed. These changes needs to be reflected in your project files for Qt Creator too, so you continue to have a nice experience coding in it. A simple way to check is to right click at your root folder in the “Projects View” and click on “Edit files…”

../../_images/qtcreator-edit-files-menu.png

Now a new dialog should appear that is similar in functionality to the one in the third step of the “Importing the project” section. Here you can check whether you want to add/remove specific files and/or folders. You can chose by clicking with your mouse or just simply by clicking the “Apply Filter” button. A simple click on “Ok” and you’re ready to continue your work.

../../_images/qtcreator-edit-files-dialog.png

代码风格配置

开发人员必须遵循项目的 代码风格,并且IDE应该帮助他们做到这一点。默认情况下,Qt Creator确实使用空格进行缩进,这对于Godot项目是不正确的。您可以通过在 选项(Options) -> C++ 中更改“代码风格(Code Style)”来更改此行为。

../../_images/qtcreator-options-cpp.png

点击 编辑(Edit) 以更改当前设置,然后点击击 复制内置代码风格(Copy Built-in Code Style) 按钮以设置新的代码风格。为它设置一个名称(例如Godot)并将制表符(Tab)策略更改为 仅制表符(Tabs Only)

../../_images/qtcreator-edit-codestyle.png

KDevelop

KDevelop 是一个适用于所有桌面平台的免费开源IDE。

您可以在 这儿 找到视频教程。当然,您也可以只是跟着后面的文本教程做。

首先打开KDevelop并选择“打开项目(open project)”。

../../_images/kdevelop_newproject.png

选择您克隆好的 Godot 源代码的目录。

在下一个画面中,为 项目管理器(Project manager) 选择“自定义构建系统(Custom Build System)”。

../../_images/kdevelop_custombuild.png

现在已经导入了项目,打开项目配置。

../../_images/kdevelop_openconfig.png

添加以下包含/导入项:

.  // a dot to indicate the root of the Godot project
core/
core/os/
core/math/
drivers/
platform/x11/  // make that platform/osx/ if you're using macOS
../../_images/kdevelop_addincludes.png

应用更改。

切换到“自定义构建系统(Custom Build System)”选项卡。添加构建配置并将构建目录保留为空。启用构建工具并添加 scons 作为可执行文件,然后添加 platform = x11 target = debug (如果您在macOS上,platform = osx)作为参数。

../../_images/kdevelop_buildconfig.png

接下来我们需要告诉KDevelop在哪里找到二进制文件。从“运行(Run)”菜单中,选择“配置启动(Configure Launches)”。

../../_images/kdevelop_configlaunches.png

如果没有启动器,请单击“添加(Add)”。然后在可执行部分中添加可执行文件的路径。您的可执行文件应该位于 bin/ 子目录中,名称应该类似于 godot.x11.tools.64 (根据您的平台和您的构建选项,名称可能会有所不同)。

../../_images/kdevelop_configlaunches2.png

好了,现在您应该学会了 :)

Xcode

项目设置

  • 在任意位置创建Xcode外部构建项目
../../_images/xcode_1_create_external_build_project.png
  • 构建工具(Build tool) 设为 scons 的路径

修改构建目标的 Xcode 信息选项卡:

  • 设置 构建参数(Arguments) 类似于: platform=osx tools=yes bits=64 target=debug
  • 目录(Directory) 设置为 Godot 源代码目录的路径。如果项目已经存在,将其保留为空。
  • 您可以取消勾选 在环境中传递构建设置(Pass build settings in environment)
../../_images/xcode_2_configure_scons.png

添加命令行目标(Command Line Target):

  • 前往 Xcode 文件(Xcode File) > 新建(New) > 目标(Target…) 添加新的Xcode命令行目标
../../_images/xcode_3_add_new_target.png ../../_images/xcode_4_select_command_line_target.png
  • 为其命名,以使您知道不使用此目标进行编译
  • 例如:GodotXcodeIndex
  • 前往新创建的目标(target)的 构建设置(Build Settings) 选项卡, 搜索 标头搜索路径(标头搜索路径)
  • 设置 标头搜索路径(Header Search Paths) 为您的 Godot 源代码目录的绝对路径
  • 通过在路径末尾添加两个 * 使其递归
  • /Users/me/repos/godot-source/\**

把 Godot 源码添加到项目:

  • 将Godot源拖放到项目文件浏览器中。
  • 取消勾选 创建外部构建系统(Create External Build System)
../../_images/xcode_5_after_add_godot_source_to_project.png
  • 点击下一步(Next)
  • 选择 建立编组(create groups)
../../_images/xcode_6_after_add_godot_source_to_project_2.png
  • 添加到目标(Add to targets) 部分中仅选中命令行目标
  • 点击完成(Finish)。Xcode将会开始索引文件。
  • 喝一杯咖啡…或者先吃点其他的东西等待一下
  • 完成之后,您就可以使用代码跳转、自动补全、完整的语法高亮等功能了。

方案设定

编辑外部构建目标的构建方案:

  • 打开外部构建目标的方案编辑器
  • 展开 构建(Build) 菜单
  • 前往 传递动作(Post Actions)
  • 添加新的脚本运行动作, 在 提供的构建设置来自于(Provide build settings from) 中选择您项目, 这样您就可以使用 ${PROJECT_DIR} 变量了。
../../_images/xcode_7_setup_build_post_action.png
  • 编写脚本,为二进制文件提供Xcode可以识别的名称
  • ln -f ${PROJECT_DIR}/godot/bin/godot.osx.tools.64 ${PROJECT_DIR}/godot/bin/godot
  • 构建外部构建目标

编辑外部构建目标的运行方案:

  • 再次打开方案(scheme)编辑器
  • 点击运行
../../_images/xcode_8_setup_run_scheme.png
  • 可执行文件(Executable) 设置为您在传递构建动作脚本中链接的文件
  • 勾选 调试可执行文件(Debug executable) (如果还未准备好)
  • 您可以前往 参数(Arguments) 选项卡然后添加 -e-path 到您的项目,来调试编辑器,而不是项目选择画面

测试:

  • platform/osx/godot_main_osx.mm 文件中设置一个断点
  • 应该能够触发您下的断点!

Visual Studio Code

  • 确保已安装C/C++扩展。您可以在 文档 中找到相关说明。
  • Open cloned godot folder in VS Code with File > Open Folder...

In order to build the project, you need two configuration files: launch.json and tasks.json. To create them:

  • Open Debug view by pressing Ctrl + Shift + D and select cogwheel with an orange dot:
../../_images/vscode_1_create_launch.json.png
  • Select C++ (GDB/LLDB) (it might be named differently on macOS or Windows)
  • 更新 launch.json 以匹配:
../../_images/vscode_2_launch.json.png

(Note that godot.x11.tools.64 in “program” value might be named differently on macOS or Windows)

  • Create tasks.json by starting the Debug process with F5. VS Code will show a dialog with a Configure Task button. Tap it and select Create tasks.json file from template, then select Others
  • 更新 tasks.json 以匹配:
../../_images/vscode_3_tasks.json.png

(注意对于macOX和Windows,platform=x11 会有所不同)

  • You can now start the Debug process again to test that everything works.
  • 如果构建阶段失败,请检查控制台以获取提示。在Linux上,很可能是缺少某些依赖项。检查 为X11平台(Linux、*BSD操作系统)编译

Android Studio

Android Studio is a JetBrains IDE for Android development. It has a feature-rich editor which supports Java and C/C++, so it can be used for development of the Godot core engine, and Android platform codebases.

项目设置

  • From the Android Studio Welcome to Android Studio window, select Open an existing Android Studio project
../../_images/android_studio_setup_project_1.png
  • Navigate to <godot root directory>/platform/android/java and select the settings.gradle gradle file.
  • Android Studio will import and index the project.
  • To build the project, follow the compiling instructions.

CLion

CLion is a commercial IDE for C++. It requires a CMakeLists.txt file as a project file, which is problematic for Godot which uses the SCons buildsystem and not CMake. However, there is a CMakeLists.txt configuration for Android Studio which can also be used by CLion.

  • Choose File -> Open.
  • Navigation to your Godot Git clone, and select the folder platform/android/java/lib (the CMakeLists.txt file is located there). Select the folder, not the CMakeLists.txt file. Then click Ok.
../../_images/clion_1_open.png
  • If this popup window appears, select This window to open the project.
../../_images/clion_2_this_window.png
  • Choose Tools -> CMake -> Change Project Root and select the root Godot folder.
../../_images/clion_3_change_project_root.png
  • You should be now be able to see all the project files. Autocomplete should work, when the project finish indexing.