Qt Creator

Qt Creator 是免費且可用於所有桌面平台的開放原始碼 IDE。

匯入專案

  • 在 Qt Creator 的主畫面中選擇 New Project > Import Project > Import Existing Project

../../../_images/qtcreator-new-project.png
  • Location 中,選擇 Godot 的根目錄。

../../../_images/qtcreator-set-project-path.png
  • 接著,可以選擇哪些資料夾於檔案要在專案中可見。雖然 C/C++ 檔案會自動新增,但也可以新增其他有用的副檔名,如: 著色器檔案 *.glsl 、建置系統檔案 *.py 、用於 Android 平台開發的 *.java 、用於 macOS 平台開發的 *.mm

../../../_images/qtcreator-apply-import-filter.png

備註

之後還能通過右鍵點擊專案並選擇 Edit Files... 選項來更改此一設定。

../../../_images/qtcreator-edit-files-menu.png
  • 完成匯入。

  • 開啟 project_name.includes 檔案,並新增一行包含 . 的內容來正確啟用程式碼補全。

../../../_images/qtcreator-project-name-includes.png
  • 在左側選單中選擇 Projects 然後開啟 Build 分頁。

  • 刪除預設的 make 建置設定。

../../../_images/qtcreator-projects-build.png
  • 點擊 Add Build Step > Custom Process Step 來新增一個新的建置步驟,並填入下列設定:

    指令

    scons

    Arguments

    有關完整的引數列表,請參考 建置系統簡介

../../../_images/qtcreator-set-scons-command.png

備註

若建置時出現如 Could not start process "scons" 這樣的錯誤,則代表 scons 不在 ``PATH``環境變數中。這時,則必須要指定 SCons 二進位檔的完整路徑。

對專案進行除錯

  • 在左側選單中選擇 Projects 並開啟 Run 分頁。

  • Executable 中指定位於 <Godot 根目錄>/bin 資料夾中的可執行檔。該執行檔的名稱會依據建置設定而有所不同,如有開啟 tools 的 64 位元 X11 版為 godot.x11.tools.64 。可以使用 %{buildDir} 來參照專案根目錄,如 %{buildDir}/bin/godot.x11.opt.tools.64

  • 若想執行特定專案,請在 Working directory 中指定專案的根目錄。

  • 若想執行編輯器,請將 -e 新增至 Command line arguments 欄位中。

../../../_images/qtcreator-run-command.png

更多有關命令行引數的資訊,請參考 命令行教學

程式碼樣式設定

開發人員必須要遵守專案的 程式碼樣式 ,而 IDE 則可以協助開發人員遵守此一樣式規範。預設情況下,Qt Creator 會使用空格來進行縮排,這樣的設定於 Godot 的程式碼樣式準則並不相符。可以在 Tools > Options > C++ 中修改 Code Style 來更改此一行為。

../../../_images/qtcreator-options-cpp.png

點擊 Edit 來更改目前的設定,然後點擊 Copy Built-in Code Style 按鈕來設定新程式碼樣式。為該樣式設定名稱 (如 Godot) 然後更改 Tab 政策為 Tabs Only

../../../_images/qtcreator-edit-codestyle.png

若遇到任何問題,請在 任何一個 Godot 的社群頻道 中尋求幫助。